Benötige Hilfe zum SIO2PC

Benötige Hilfe zum SIO2PC
11.01.2020 um 18:40 Uhr von voltac
Hallo
Ich weiss...zu dem Thema gibt es sehr viele Threads.
Habe gelesen und gelesen gegooglet
Bekomme aber leider keine Verbindung zwischen 800XL und dem PC(Ubuntu 18.4) hin.
Habe RespeQt und AspeQt ausprobiert.

Habe diese Hardware:
https://www.amazon.de/AZDelivery-Adapte ... 024&sr=8-3

und so verkabelt wie links oben im Bild
https://atariage.com/forums/topic/24252 ... nt=3581572

Bin dankbar über Tipps

gruss
voltac
Re: Benötige Hilfe zum SIO2PC
12.01.2020 um 09:24 Uhr von JoSch
Hallo.

Kannst Du bitte schildern, wie Du RespeQt einrichtest?
Wenn Du unten rechts auf das Icon mit den zwei Steckern guckst, sind Stecker verbunden oder nicht?
Steht eine Fehlermeldung im unteren Logbereich?


Grüße

Jochen
Re: Benötige Hilfe zum SIO2PC
Benutzeravatar12.01.2020 um 09:48 Uhr von dl7ukk
Hi,

angeschlossen sollte es soweit richtig sein.

auch mal ohne Diode probieren (dann nur ein SIO Gerät!)
Stimmt der USB Port (/dev/ttyUSB??)
Richtiges Handshake Leitung/ Signal verwendet
Mal ohne Handshake probiert?

1.png
1.png (56.69 KiB) 218-mal betrachtet


Da Du Linux benutzt, schau Dir mal das atarisio von Hias an. Es ist für die Konsole und läuft prima.
Link
Re: Benötige Hilfe zum SIO2PC
12.01.2020 um 14:44 Uhr von voltac
JoSch hat geschrieben:Hallo.

Kannst Du bitte schildern, wie Du RespeQt einrichtest?
Wenn Du unten rechts auf das Icon mit den zwei Steckern guckst, sind Stecker verbunden oder nicht?
Steht eine Fehlermeldung im unteren Logbereich?


Grüße

Jochen


Ja..die 2 Stecker sind verbunden.
Hier mal ein Auszug des Logs:
Geschwindigkeit des seriellen Ports ist gesetzt auf 19200."
Emulation gestartet über serielles Port Backend auf 'ttyUSB0' mit DSR Handshaking."

solage der A8 beim start rattert bekomme ich laufenden diese Meldung im Log Fenster:
Geschwindigkeit des seriellen Ports ist gesetzt auf 19200."
Serial port read timeout. 0 of 5 read in 103 ms" [x2]
Geschwindigkeit des seriellen Ports ist gesetzt auf 19200."
Serial port read timeout. 0 of 5 read in 103 ms"
.
.
.
Re: Benötige Hilfe zum SIO2PC
12.01.2020 um 14:52 Uhr von voltac
dl7ukk hat geschrieben:Hi,

angeschlossen sollte es soweit richtig sein.

auch mal ohne Diode probieren (dann nur ein SIO Gerät!)
Stimmt der USB Port (/dev/ttyUSB??)
Richtiges Handshake Leitung/ Signal verwendet
Mal ohne Handshake probiert?

Da Du Linux benutzt, schau Dir mal das atarisio von Hias an. Es ist für die Konsole und läuft prima.
Link


Die Diode habe ich noch nicht drin....da ich noch keine weitere Atari Hadware habe.
Der USB Port sollte mit /dev/ttyUSB richt sein.
Ich denke ich habe jetzt so alle Kombinationen durch :mrgreen:
Nur bei der Kombination ttyUSB0 DSR bekomme ich eine Reaktion im Log Fenster
Die ich im Post hier drüber beschrieben habe
Re: Benötige Hilfe zum SIO2PC
12.01.2020 um 16:13 Uhr von JoSch
1.) Wenn es einen Timeout gibt, kann etwas nicht stimmen. Ist Dein Benutzer in der Benutzergruppe dialup oder dialout (weiß jetzt nicht wie genau die Gruppe bei Ubuntu heißt, steht aber in /etc/groups)?
Der Benutzer sollte in der Benutzergruppe dort sein, sonst kann kein Programm auf tty-Geräte zugreifen.
2.) Gibt es noch andere USB-serielle Geräte? Was gibt ls /dev/ttyUSB* aus?


Grüße

Jochen
Re: Benötige Hilfe zum SIO2PC
Benutzeravatar12.01.2020 um 16:15 Uhr von dl7ukk
Hi,

voltac hat geschrieben:Geschwindigkeit des seriellen Ports ist gesetzt auf 19200."
Emulation gestartet über serielles Port Backend auf 'ttyUSB0' mit DSR Handshaking."

Geschwindigkeit des seriellen Ports ist gesetzt auf 19200."
Serial port read timeout. 0 of 5 read in 103 ms" [x2]
Geschwindigkeit des seriellen Ports ist gesetzt auf 19200."
Serial port read timeout. 0 of 5 read in 103 ms"


Wenn ich die Meldungen richtig verstehe, wurde der Port erkannt, auf Standard Sio-Geschwindigkeit eingestellt, aber es kommen keine Daten/ Antworten vom XL.

Also nochmal schauen, ob die Verdrahtung in Ordnung ist, der XL mit anderen Sio-Geräten läuft, in dieser Richtung würde ich suchen.

Gruß
Re: Benötige Hilfe zum SIO2PC
Benutzeravatar12.01.2020 um 17:03 Uhr von dl7ukk
Hi,
JoSch hat geschrieben:1.) Wenn es einen Timeout gibt, kann etwas nicht stimmen. Ist Dein Benutzer in der Benutzergruppe dialup oder dialout (weiß jetzt nicht wie genau die Gruppe bei Ubuntu heißt, steht aber in /etc/groups)?
Der Benutzer sollte in der Benutzergruppe dort sein, sonst kann kein Programm auf tty-Geräte zugreifen.
2.) Gibt es noch andere USB-serielle Geräte? Was gibt ls /dev/ttyUSB* aus?


Grüße

Jochen


Das passt gerade ....
ich habe hier einen Rechner mit jungfräulichem Ubuntu 18.04 und da ist der "Standard" User nicht(!) in der Gruppe dialout.

Überprüfen kannst Du das auf der Konsole mit :$ id
und setzen mit : $ sudo usermod -aG dialout BENUTZERNAME

Gruß
Re: Benötige Hilfe zum SIO2PC
Benutzeravatar12.01.2020 um 18:23 Uhr von atarixle
Ganz doof gefragt: hast du ein Disketten-Image "eingelegt"?

Ist auch ja keine aktive Laufwerksnummer mehrfach vergeben (echtes Laufwerk und RespeQt)?
Re: Benötige Hilfe zum SIO2PC
12.01.2020 um 18:26 Uhr von voltac
atarixle hat geschrieben:Ganz doof gefragt: hast du ein Disketten-Image "eingelegt"?

Ist auch ja keine aktive Laufwerksnummer mehrfach vergeben (echtes Laufwerk und RespeQt)?


Habe kein echtes Laufwerk
Jepp...habe ein Disk Image "eingelegt" eine ATR Datei
Re: Benötige Hilfe zum SIO2PC
12.01.2020 um 18:27 Uhr von voltac
Bin auch in der Dialout gruppe
Re: Benötige Hilfe zum SIO2PC
Benutzeravatar12.01.2020 um 22:21 Uhr von atarixle
Wenn RespeQt überhaupt auf den Atari reagiert, in welcher Weise auch immer, dann steht die Verbindung ja schonmal. Dann stimmt auch die Gruppe (dialout) und das Gerät (ttyUSB*).

Ich würde jetzt alles, was Highspeed ist, in RespeQt abschalten und versuchen, ein einfaches 130kB großes DOS2.5-Image von D1: zu booten.
Re: Benötige Hilfe zum SIO2PC
Benutzeravatar12.01.2020 um 23:42 Uhr von dl7ukk
Hi,

Ist Dein ATR wirklich bootfähig?

Hier ist ein bootfähiges ATR

BIBO54RN.ATR
(90.02 KiB) 3-mal heruntergeladen

probiere doch mal damit


Gruß
Re: Benötige Hilfe zum SIO2PC
Benutzeravatar13.01.2020 um 08:47 Uhr von tfhh
Moin,

dl7ukk hat geschrieben:Ist Dein ATR wirklich bootfähig?

Der Threadstarter schreibt ja "Rattern"... das heißt, es wird kein Sektor gelesen. Sonst würde bei einer nicht bootfähigen Diskette zumindest "BOOT ERROR" erscheinen.

Gruß, Jürgen
Re: Benötige Hilfe zum SIO2PC
Benutzeravatar13.01.2020 um 08:52 Uhr von atarixle
Das weist mMn auf ein leeres Laufwerk 1.
Re: Benötige Hilfe zum SIO2PC
Benutzeravatar13.01.2020 um 08:54 Uhr von tfhh
Moin,

voltac hat geschrieben:Bekomme aber leider keine Verbindung zwischen 800XL und dem PC(Ubuntu 18.4) hin.
Habe RespeQt und AspeQt ausprobiert.

Habe diese Hardware:
https://www.amazon.de/AZDelivery-Adapte ... 024&sr=8-3

und so verkabelt wie links oben im Bild
https://atariage.com/forums/topic/24252 ... nt=3581572

Überprüfe nochmal genau die Verkabelung, bitte. Die Bilder sind teilweise irreführend - die blaue Leitung geht im rechten Muster an CTS, was falsch ist.

Für eine funktionierende SIO2PC-irgendetwas Verbindung brauchst Du TxD, RxD und eine Handshake-Leitung. Vom Erfinder (Nick Kennedy) der ersten SIO2PC DOS Software wurde "RI" (Ring Indicator) vorgesehen. Unter Windows 95/98 gab das bei einigen Usern Probleme, weswegen optional auch DSR in die Software eingebaut wurde. umgestiegen ist. Selten gibt es auch RTS, das empfehle ich aber ausdrücklich nicht. Die beiden modernen ReseQt/AspeQt Hosts bedienen alle drei Optionen.

Prüfe also, ob AspeQt/RespeQt auf DSR steht und die Verbindung von Pin 7 der SIO Schnittstelle auch wirklich zu DSR des FTDI Wandlers geht.

Viel Erfolg, Jürgen
Re: Benötige Hilfe zum SIO2PC
13.01.2020 um 21:25 Uhr von voltac
atarixle hat geschrieben:Das weist mMn auf ein leeres Laufwerk 1.

Habe in Laufwerk 1 eine ATR Datei eingelegt...DIe 2 Stecker Symbole sind dann unten rechts verbunden.
Es erscheint dann im Log Fenster:

[Disk 1] Mounted BIBO54RN.ATR as SD Diskette (90K)

Dann starte ich bei gedrückter Option Taste den 800XL.
Dann sollte er die Diskette lesen...oder?
Re: Benötige Hilfe zum SIO2PC
13.01.2020 um 21:39 Uhr von voltac
tfhh hat geschrieben:Moin

Überprüfe nochmal genau die Verkabelung, bitte. Die Bilder sind teilweise irreführend - die blaue Leitung geht im rechten Muster an CTS, was falsch ist.

Für eine funktionierende SIO2PC-irgendetwas Verbindung brauchst Du TxD, RxD und eine Handshake-Leitung. Vom Erfinder (Nick Kennedy) der ersten SIO2PC DOS Software wurde "RI" (Ring Indicator) vorgesehen. Unter Windows 95/98 gab das bei einigen Usern Probleme, weswegen optional auch DSR in die Software eingebaut wurde. umgestiegen ist. Selten gibt es auch RTS, das empfehle ich aber ausdrücklich nicht. Die beiden modernen ReseQt/AspeQt Hosts bedienen alle drei Optionen.

Prüfe also, ob AspeQt/RespeQt auf DSR steht und die Verbindung von Pin 7 der SIO Schnittstelle auch wirklich zu DSR des FTDI Wandlers geht.

Viel Erfolg, Jürgen


Habe den roten FTDI nicht den blauen.Die Verkabelung habe ich mehrmals überprüft.
Habe mal pin7 von der SIO Buchse des 800XL auf RI des FTDI gelötet....leider auch kein Erfolg.
In AspeQt/RespeQt habe ich entsprechend die Handshake Methode dann auf RI eingestellt.

Bei AspeQt kommt im Log Fenster eine Meldung die bis 42 hochzählt,solange der 800XL rattert.
Was auch so war als ich PIN7 der SIO Buchse auf DSR gelötet hatte.

Habe mal den gesockelten Pokey rausgenommen,pins mit einem Glashaarradierer gereinigt.
Wobei die pins alle gut aussahen.Dann alle ICs in den Sockeln nachgedrückt.
Leider hat das auch nichts gebracht.
Re: Benötige Hilfe zum SIO2PC
Benutzeravatar14.01.2020 um 02:00 Uhr von dl7ukk
Hallo,

voltac hat geschrieben:Habe mal pin7 von der SIO Buchse des 800XL auf RI des FTDI gelötet....leider auch kein Erfolg.
In AspeQt/RespeQt habe ich entsprechend die Handshake Methode dann auf RI eingestellt.


hast Du es mal ohne Handshake versucht ....

Gruß
Re: Benötige Hilfe zum SIO2PC
Benutzeravatar14.01.2020 um 10:39 Uhr von tfhh
Moin,

voltac hat geschrieben:Bei AspeQt kommt im Log Fenster eine Meldung die bis 42 hochzählt,solange der 800XL rattert. Was auch so war als ich PIN7 der SIO Buchse auf DSR gelötet hatte.

Dann scheint der XL die Antwort nicht zu bekommen. Du kannst es (fest auf 19200 bps eingestellt) auch mal ohne Handshake probieren wie Andreas schrieb, aber ich denke, das wird ebensowenig funktionieren.

Hast Du den XL denn mit anderen SIO Geräten schon mal geprüft (vorzugsweise Diskettenstation, 850er etc.)? Evtl. ist schlicht etwas defekt am Rechner.

Grüße, Jürgen
auf ABBUC.de antwortenauf ABBUC.de lesen alle aktiven ABBUC-Forum-Themen zurück zu atarixle.de