TK-II-Stereo Board Frage

TK-II-Stereo Board Frage
Benutzeravatar13.11.2020 um 18:25 Uhr von 24sumo
Hallo Gemeinde,
auf Sellmyretro.com habe ich das fertige TK-II-Stereo Board erworben, wollte eigentlich nur den Dual Pokey Sound - die Anschlussmöglichkeit für Tastatur/Maus ist bei mir nicht im Vordergrund des Erwerbs gewesen.
Das Board (https://ataribits.weebly.com/tk-ii-stereo.html) kam ohne Interface-Anschluss und Kabel, aber nicht schlimm - eine Klinkenbuchse kriege ich auch so dran...
Allerdings habe ich ein Problem mit der internen Tastatur (800 XL), die funktioniert nämlich nicht mehr nach dem Einbau (Reset, Start, Option, Select gehen). Ist das normal wenn das Board ggf. noch nie mit Firmware versehen wurde? Einen Joy2Pic (https://ataribits.weebly.com/joy2pic.html) habe ich nämlich nicht zum Programmieren.
Ich hätte erwartet, dass die Firmware nur für die Übersetzung der Signale der PS2 Geräte in Atari kompatible Signale gebraucht wird. PS2 Anschluss soll z.Z. noch nicht dran.
Beide Pokeys haben im Zusatzboard Strom und Tastatur funktioniert mit diesen auch direkt im Motherboard.
Hat jemand einen Tipp :?:
Danke und Grüße
Bernhard
Re: TK-II-Stereo Board Frage
13.11.2020 um 20:14 Uhr von pps
The TK-II can either take over completely, as is the case for the TK-II-GS model, or serve as an adjunct to the original stock keyboard, allowing both to work in concert.

Das steht auf der Webpage zum TK II Board (ohne Stereo Pokeys). Vielleicht muss man da was anders löten oder es gibt einen Jumper, den man umstecken muß.
Das Board scheint entweder die originale Tastatur zu ersetzen oder eben zu ergänzen.
Re: TK-II-Stereo Board Frage
Benutzeravatar13.11.2020 um 20:36 Uhr von 24sumo
Danke für dein Feedback.
Wobei ich die Aussage nicht als exklusiv oder (entweder oder), sondern als echtes oder verstehen würde. D.h. es geht beides parallel, habe auch nichts gefunden zum konfigurieren...

Mehr Ideen?
Bernhard
Re: TK-II-Stereo Board Frage
Benutzeravatar13.11.2020 um 23:15 Uhr von Bernd
Hast du die Adressleitung A4 an Pin2 von J3 angeschlossen?
Wenn die fehlt gibt es Probleme.....
Re: TK-II-Stereo Board Frage
Benutzeravatar13.11.2020 um 23:51 Uhr von 24sumo
Ja, gerade noch mal geprüft.
Habe diese Vorlage aus dem AtariAge Forum als Installanleitung genommen.
https://i.imgur.com/uxK7ZsJ.jpg

https://atariage.com/forums/topic/25488 ... reo&page=1

Schaltplan:
https://i.imgur.com/3I5y8Au.png

Tastatursteuerung läuft nur über Pokey-L (den Originalen) und der 74HC4066 schaltet dann das Chip Select für die Pokeys. Ich schau noch mal...
Bernhard
Re: TK-II-Stereo Board Frage
Benutzeravatar14.11.2020 um 00:52 Uhr von 24sumo
Chip Select CS0 & CS1 passt bei 1 und 2 gesteckten Pokeys, daran sollte es nicht liegen.
Details zur Funktionsweise hier (auch wenn von einem anderen Upgrade):
http://vybostok.com/8bit-atari/dual-pokey-gumby-2-0/

Ehrlich gesagt wenn der 1. Pokey nur huckepack verbaut ist und Leitungen nur durchgeschleift sind... verstehe ich nicht warum das Verhalten unterschiedlich (mit und ohne Board) ist. Muss noch mal die Verbindungen durchklingeln.

Bernhard
Re: TK-II-Stereo Board Frage
Benutzeravatar14.11.2020 um 01:13 Uhr von Bernd
Zieh mal den Pic heraus und teste es ohne ihn noch mal.
Re: TK-II-Stereo Board Frage
Benutzeravatar14.11.2020 um 11:26 Uhr von 24sumo
Ja, genau dies hatte ich mir auch überlegt. Der wird ohne Firmware irgendwie Mist abliefern.
Leider ist bis auf die Pokeys nichts gesockelt.

Bis später...
Bernhard
Re: TK-II-Stereo Board Frage
Benutzeravatar14.11.2020 um 12:46 Uhr von tfhh
Moin,

24sumo hat geschrieben:auf Sellmyretro.com habe ich das fertige TK-II-Stereo Board erworben, wollte eigentlich nur den Dual Pokey Sound - die Anschlussmöglichkeit für Tastatur/Maus ist bei mir nicht im Vordergrund des Erwerbs gewesen.
Allerdings habe ich ein Problem mit der internen Tastatur (800 XL), die funktioniert nämlich nicht mehr nach dem Einbau (Reset, Start, Option, Select gehen). Ist das normal wenn das Board ggf. noch nie mit Firmware versehen wurde? Einen Joy2Pic (https://ataribits.weebly.com/joy2pic.html) habe ich nämlich nicht zum Programmieren.

Eigentlich gehe ich davon aus, daß die Firmware aufgespielt wurde :roll:

Unabhängig davon: Das ist normal, die interne Tastatur ist ohne Funktion. Es könnte sogar sein, daß auch die PS/2 Tastatur nicht funktioniert. Die Leitungen KR1, KR2, K0, K1 und K2 sind Eingänge am POKEY und für die Tastaturmatrix zuständig. Das bedeutet, sowohl der 4051 auf der Atari Hauptplatine als auch der PIC legen ihr ihre Ausgänge an - Ausgang an Ausgang bei TTL ist nix gut. Da die Schaltung und auch der Atari hier keine Open Collector/Open Drain Beschaltung vorsieht, mußt Du entweder den PIC entfernen oder den 4051 (U24 beim 800XL), der als Eingangs-Decoder arbeitet.

Alternativ kann ich Dir anbieten, dieses TKII gegen einer meiner Stereo-Boards zu tauschen, ich werden demnächst aufgrund kleiner Nachfrage nochmal 5 Stück auflegen. Wenn Interesse --> EMail.

Grüße, Jürgen
Re: TK-II-Stereo Board Frage
Benutzeravatar14.11.2020 um 18:15 Uhr von 24sumo
OK, auch hier Danke für die Erklärung. Die Funktion hätte auf Atariage oder der Homepage besser erklärt werden können, speziell wie es sich mit einer vorhandenen internen Tastatur verhält. Mal sehen was ich mache...
Würde es reichen wenn ich den Pic von der Stromversorgung auf der Platine trenne? (Leiterbahn durchkratzen)
Grüße
Bernhard
Re: TK-II-Stereo Board Frage
Benutzeravatar14.11.2020 um 19:39 Uhr von Bernd
24sumo hat geschrieben:Würde es reichen wenn ich den Pic von der Stromversorgung auf der Platine trenne? (Leiterbahn durchkratzen)
...


Nein, bitte nicht. Der PIC ist ein Prozessor und benötigt eine lauffähige Software. Erfolgt keine Pin Initialisierung in der Software, blockiert der Chip die Datenübertragung zum Atari. Die +5V nur entfernen reicht nicht aus, der CHip muss ausgelötet werden.
Re: TK-II-Stereo Board Frage
Benutzeravatar14.11.2020 um 20:18 Uhr von dinadan
24sumo hat geschrieben:Allerdings habe ich ein Problem mit der internen Tastatur (800 XL), die funktioniert nämlich nicht mehr nach dem Einbau (Reset, Start, Option, Select gehen). Ist das normal wenn das Board ggf. noch nie mit Firmware versehen wurde? Einen Joy2Pic (https://ataribits.weebly.com/joy2pic.html) habe ich nämlich nicht zum Programmieren.
Ich hätte erwartet, dass die Firmware nur für die Übersetzung der Signale der PS2 Geräte in Atari kompatible Signale gebraucht wird. PS2 Anschluss soll z.Z. noch nicht dran.


Jon (FlashJazzCat) hatte das gleiche Problem nachdem er das Board in meinen 800XL eingebaut hatte. Seine Lösung erfordert allerdings, eine PS/2-Tastatur angeschlossen zu haben. Ich zitiere mal aus seiner Mail:

"Well – that was quick. Mytek replied and I had to press CTRL+ALT+X to take the TK-II out of XEGS mode. This results in the internal keyboard working just fine, and the setting is permanent (until changed again)."
Re: TK-II-Stereo Board Frage
Benutzeravatar14.11.2020 um 21:52 Uhr von 24sumo
Ok, Danke für die Hinweise. Dann probiere ich es mal mit externer Tastatur, dann sehe ich ob die Firmware schon drauf war. Und ja, Auslöten wäre die saubere Variante - wenn gar nichts geht, der Klau der Versorgungsspannung wäre quick & dirty gewesen und mir war klar dass diese Variante keine Begeisterung auslösen wird. Gut dass ich jetzt weiß dass es dann auch Probleme geben kann.
Grüße
Bernhard
Re: TK-II-Stereo Board Frage
Benutzeravatar15.11.2020 um 00:09 Uhr von 24sumo
dinadan hat geschrieben:
24sumo hat geschrieben:Allerdings habe ich ein Problem mit der internen Tastatur (800 XL), die funktioniert nämlich nicht mehr nach dem Einbau (Reset, Start, Option, Select gehen). Ist das normal wenn das Board ggf. noch nie mit Firmware versehen wurde? Einen Joy2Pic (https://ataribits.weebly.com/joy2pic.html) habe ich nämlich nicht zum Programmieren.
Ich hätte erwartet, dass die Firmware nur für die Übersetzung der Signale der PS2 Geräte in Atari kompatible Signale gebraucht wird. PS2 Anschluss soll z.Z. noch nicht dran.


Jon (FlashJazzCat) hatte das gleiche Problem nachdem er das Board in meinen 800XL eingebaut hatte. Seine Lösung erfordert allerdings, eine PS/2-Tastatur angeschlossen zu haben. Ich zitiere mal aus seiner Mail:

"Well – that was quick. Mytek replied and I had to press CTRL+ALT+X to take the TK-II out of XEGS mode. This results in the internal keyboard working just fine, and the setting is permanent (until changed again)."


Hell yeah, dein Hinweis hat funktioniert. :notworthy:
Musste mir erstmal Kabel zusammen basteln (eine PS2 Buchse habe ich nicht da gehabt) und konnte eben testen. Die externe Tastatur hat funktioniert (d.h. die Firmware war drauf) und ich konnte die Tastenkombination nutzen und danach habe ich die interne Tastatur angeschlossen und die funktioniert jetzt. Viel gelernt heute... :idea:
Morgen wird dann alles korrekt zusammen gebaut und getestet.

Danke an alle Tippgeber und Erklärer! :beer:
Grüße
Bernhard
auf ABBUC.de antwortenauf ABBUC.de lesen alle aktiven ABBUC-Forum-Themen zurück zu atarixle.de