Update-Problem

Moderator: Sleeπ

Gesperrt
Benutzeravatar
Sleeπ
Beiträge: 723
Registriert: 18. Jun 2021, 20:58
Has thanked: 4 times
Been thanked: 49 times
Kontaktdaten:

Update-Problem

Beitrag von Sleeπ »

Hi,

wir haben einige aktuelle Fujinet (1.5) geupdated. Ein Gerät ging nicht von selbst in den "Update Mode". Wie auf AA beschrieben, haben wir es mit gehaltener "A"-Taste (am Fujinet) via USB mit dem PC verbunden und dann das Update durchgeführt.
Then we can update it, but after update, the last message in the console-window looks like this:

Am Ende des Update steht im Console-Fenster des Update-Programms folgendes:

Code: Alles auswählen

Leaving...
Hard Resetting...
Done! Flashing is complete!"

Showing logs:
Wieder am XL angeschlossen, bootet dieser nicht mehr von dem Fujinet; es ist quasi unsichtbar.


Bei einem anderen Fujinet sieht die Ausgabe nach dem Update wie folgt aus:

Code: Alles auswählen

Leaving...
Hard Resetting...
Done! Flashing is complete!

Showing logs:
[15:38:07]
[15:38:07]
[15:38:07]--~--~--~--
[15:38:07]FujiNet 0.5.ba2f6751 2021-07-27 12:03:04 Started @ 4
[15:38:07]Starting heap: 4054556
[15:38:07]PsramSize 3917592
[15:38:07]himem phys 4456448
[15:38:07]himem free 4456448
[15:38:07]himem reserved 262144
[15:38:07]Detected Hardware Version: 1.1-1.5
[15:38:07]Enabled Safe Reset Button C
[15:38:07]SPIFFS mounted.
[15:38:07]E (1134) vfs_fat_sdmmc: sdmmc_card_init failed (0x107).
[15:38:07]SD mount failed with code #263, "ESP_ERR_TIMEOUT"
[15:38:07]fnConfig::load
[15:38:07]Load fnconfig.ini from spiffs
[15:38:07]fnConfig::load read 264 bytes from config file
[15:38:07]SPIFFS Config Storage: Enabled
[15:38:07]fnConfig::load read 264 bytes from SPIFFS config file
[15:38:07]WIFI_EVENT_STA_START
[15:38:07]disk UNMOUNT
[15:38:07]disk MOUNT
[15:38:07]ATR MOUNT
[15:38:07]mounted ATR: paragraphs=5760, sect_size=128, sect_count=720, disk_size=0
[15:38:07]Creating a default printer using FS_SPIFFS storage and type 1
[15:38:07]SSH client initialized.
[15:38:07]ModemSniffer::ModemSniffer(FS_SPIFFS)
[15:38:07]SIO SETUP
[15:38:07]Set HSIO baud from 0 to 67431 (index 6), alt=68209
[15:38:07]Available heap: 3965864
[15:38:07]Setup complete @ 457 (453ms)
Es scheint dass das Fujinet nach dem Update nicht mehr neu startet.

Was können wir probieren um das Teil wieder zum Leben zu erwecken?
Sleeπ

Benutzeravatar
DjayBee
Beiträge: 44
Registriert: 17. Aug 2021, 04:02
Has thanked: 13 times
Been thanked: 4 times
Kontaktdaten:

Re: Update-Problem

Beitrag von DjayBee »

Ich hatte mit dem, das ich vorher von der Fujiama mitgenommen habe, dasselbe Problem.

Bei mir war es sogar noch blöder weil ich einige Versuche an mehreren PCs benötigt habe, bis es am USB erkannt wurde. Zum Schluss hat es dann an dem PC und mit dem USB-Kabel funktioniert, die ich als erstes versucht hatte.

Nachdem ich es komplett stromlos gemacht habe (also USB und Atari ausgesteckt), hat es dann auch mit der neuen Firmware am Atari funktioniert.

Benutzeravatar
Mathy
Beiträge: 226
Registriert: 18. Jun 2021, 11:13
Wohnort: Heerlen, NL
Has thanked: 34 times
Been thanked: 30 times
Kontaktdaten:

Re: Update-Problem

Beitrag von Mathy »

Hallo DjayBee

Luckybuck lässt sich gerade von bitbastel erklären was los ist. Damit luckybuck dann tschak909 erläutern kann was los ist und dieser hoffentlich mit einer Lösung kommt.

Tschüß

Mathy

PS sleepy hat mir gefragt das hier zu schreiben.
Wer oder was hat denn da geblitzt?

Benutzeravatar
Sleeπ
Beiträge: 723
Registriert: 18. Jun 2021, 20:58
Has thanked: 4 times
Been thanked: 49 times
Kontaktdaten:

Re: Update-Problem

Beitrag von Sleeπ »

Es wird an der Lösung gearbeitet. :-)

Bis dahin schließe ich das Thema, damit es nicht an zu vielen Stellen parallele Diskussionen gibt.

Anmerkung von skr: Alle FujiNet-Module, die vom ABBUC ausgeliefert werden, sind getestet und funktionieren. Bitte auf keinen Fall ein Firmware-Update versuchen, solange wir (bzw. die Entwickler des FujiNet) das Problem nicht gelöst haben (was wir hier bekannt geben).
Sleeπ

Benutzeravatar
Sleeπ
Beiträge: 723
Registriert: 18. Jun 2021, 20:58
Has thanked: 4 times
Been thanked: 49 times
Kontaktdaten:

Re: Update-Problem

Beitrag von Sleeπ »

Auf AA wird an der Lösung gearbeitet:

klick
Sleeπ

Gesperrt

Wer ist online?

Mitglieder in diesem Forum: andymanone, LarryL und 1 Gast