RespeQt 5.4 RC3

Alles rund um den ABBUC und Atari, was nicht in die anderen Kategorien passt.
Online
JoSch
Beiträge: 200
Registriert: 25.08.2021 21:40
Has thanked: 91 times
Been thanked: 72 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von JoSch »

Ich habe gerade die neue Version 5.4.0 H.A.T.Z. Edition veröffentlicht.
Ich habe unter anderem noch die Logausgabe begrenzt, so dass bei längerer Benutzung keine Crashes mehr vorkommen sollten.
https://github.com/josch1710/RespeQt/re ... tag/r5.4.0

Viel Spass.

Currock
Beiträge: 42
Registriert: 18.08.2021 17:31
Has thanked: 3 times
Been thanked: 3 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von Currock »

JoSch hat geschrieben:
05.05.2024 13:09
Siehst Du irgendwelche SIO-Meldugen im Logbereich unten (Strg+L macht ein Extrafenster auf). Wenn nicht, dann ist der Handshake falsch. Wenn doch, was steht drin.
Hast Du die ganzen SIO-Geräte noch angesteckt? Wenn ja, was passiert, wenn Du nur den SIO2USB ansteckst?
Keine Fehlermeldungen. Der Port wird immer mit 19200 Baud geöffnet, egal, was ich einstelle. Handshake habe ich alle Varianten durch, keine Funktion.
Die Meldungen im Logfenster zeigen immer, dass der Port mit 19200 Baud geöffnet wurde, und mit den entsprechenden Handshake-Einstellungen. Dann wird noch angezeigt, dass das Image eingebunden wurde (zum Testen ein einfaches DOS 2.5.atr.

Online
JoSch
Beiträge: 200
Registriert: 25.08.2021 21:40
Has thanked: 91 times
Been thanked: 72 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von JoSch »

Komisch, ich hatte mit der Version auf Windows in den letzten keine Probleme.
Welches Betriebssystem benutzt Du?

Benutzeravatar
Major Blink
Beiträge: 56
Registriert: 14.10.2021 18:50
Has thanked: 31 times
Been thanked: 19 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von Major Blink »

Currock hat geschrieben:
12.05.2024 16:45
JoSch hat geschrieben:
05.05.2024 13:09
Siehst Du irgendwelche SIO-Meldugen im Logbereich unten (Strg+L macht ein Extrafenster auf). Wenn nicht, dann ist der Handshake falsch. Wenn doch, was steht drin.
Hast Du die ganzen SIO-Geräte noch angesteckt? Wenn ja, was passiert, wenn Du nur den SIO2USB ansteckst?
Keine Fehlermeldungen. Der Port wird immer mit 19200 Baud geöffnet, egal, was ich einstelle. Handshake habe ich alle Varianten durch, keine Funktion.
Die Meldungen im Logfenster zeigen immer, dass der Port mit 19200 Baud geöffnet wurde, und mit den entsprechenden Handshake-Einstellungen. Dann wird noch angezeigt, dass das Image eingebunden wurde (zum Testen ein einfaches DOS 2.5.atr.
Hast Du auch den FTDI-Treiber installiert?
Dateianhänge
manual.pdf
(835.38 KiB) 4-mal heruntergeladen

Benutzeravatar
GoodByteXL
Beiträge: 265
Registriert: 18.08.2021 12:10
Has thanked: 6 times
Been thanked: 60 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von GoodByteXL »

JoSch hat geschrieben:
10.05.2024 09:28
Ich habe gerade die neue Version 5.4.0 H.A.T.Z. Edition veröffentlicht.
Ich habe unter anderem noch die Logausgabe begrenzt, so dass bei längerer Benutzung keine Crashes mehr vorkommen sollten.
https://github.com/josch1710/RespeQt/re ... tag/r5.4.0

Viel Spass.
Ich war längere Zeit offline ...

Was ich vermisse, ist eine portable Version für Linux, wie sie früher Mirko erstellt hatte. In github kann ich nur zu installierende oder zu kompilierende Versionen finden.

Eine Version wie die letzte von Mirko erstellte Fassung http://atarixle.ddns.net/download/respe ... _64.tar.xz wäre hilfreich (für mich zumindest).

tomsmart1
Beiträge: 10
Registriert: 17.08.2021 09:37
Has thanked: 11 times
Been thanked: 2 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von tomsmart1 »

Wie am Samstag abgesprochen habe ich die HATZ Edition mit meinem Selbstbauadapter mit FTDI Chip getestet. Diese funktioniert hier mit Windows 10 64.bit habe das Archiv ".zip" verwendet als auch mit Linux Mint 21.3 Cinnamon 64-bit mit der ".deb" Datei auf einem 6 Jahre alten PC. Eine Übertragung mit POKEY Divisor 0 funktioniert Problemlos mit der PBI HighSIO Treiber der Ultimate1MB mit flashjazzcat Version 4.20 Firmware.

Online
JoSch
Beiträge: 200
Registriert: 25.08.2021 21:40
Has thanked: 91 times
Been thanked: 72 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von JoSch »

GoodByteXL hat geschrieben:
14.05.2024 08:29
JoSch hat geschrieben:
10.05.2024 09:28
Ich habe gerade die neue Version 5.4.0 H.A.T.Z. Edition veröffentlicht.
Ich habe unter anderem noch die Logausgabe begrenzt, so dass bei längerer Benutzung keine Crashes mehr vorkommen sollten.
https://github.com/josch1710/RespeQt/re ... tag/r5.4.0

Viel Spass.
Ich war längere Zeit offline ...

Was ich vermisse, ist eine portable Version für Linux, wie sie früher Mirko erstellt hatte. In github kann ich nur zu installierende oder zu kompilierende Versionen finden.

Eine Version wie die letzte von Mirko erstellte Fassung http://atarixle.ddns.net/download/respe ... _64.tar.xz wäre hilfreich (für mich zumindest).
Ich habe auch eine gezippte Datei hinterlegt. RespeQt muss dabei mit dem Shellskript gestartet werden. Funktioniert diese Version nicht bei Dir?

Benutzeravatar
dl7ukk
Beiträge: 554
Registriert: 25.08.2021 23:03
Has thanked: 77 times
Been thanked: 106 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von dl7ukk »

Hi,

hier klemmt es auch mit dem zip unter Ubuntu-Mate 22.04
(Quelltext wollte ich jetzt nicht probieren. Da ich das zu selten mache, endet es oft in einer abendfüllende "Veranstaltung")
Danke für Deine Mühe!!

Code: Alles auswählen

dl7ukk@Hp635b:~/ATARI/Respe$ ll
insgesamt 60
drwxrwxr-x 12 dl7ukk dl7ukk  4096 Mai 14 09:30 ./
drwxrwxr-x 75 dl7ukk dl7ukk 12288 Mai 14 09:30 ../
drwx------  2 dl7ukk dl7ukk  4096 Mai 14 09:30 bin/
drwx------  2 dl7ukk dl7ukk  4096 Mai 14 09:30 bootata/
drwx------  2 dl7ukk dl7ukk  4096 Mai 14 09:30 bootdxl/
drwx------  2 dl7ukk dl7ukk  4096 Mai 14 09:30 bootmyd/
drwx------  2 dl7ukk dl7ukk  4096 Mai 14 09:30 bootpic/
drwx------  2 dl7ukk dl7ukk  4096 Mai 14 09:30 bootsma/
drwx------  2 dl7ukk dl7ukk  4096 Mai 14 09:30 bootspa/
drwx------  2 dl7ukk dl7ukk  4096 Mai 14 09:30 lib/
drwx------ 10 dl7ukk dl7ukk  4096 Mai 14 09:30 plugins/
-rwxrw-r--  1 dl7ukk dl7ukk  1635 Mai 10 06:19 RespeQt.sh*
drwx------  2 dl7ukk dl7ukk  4096 Mai 14 09:30 translations/
dl7ukk@Hp635b:~/ATARI/Respe$ ./RespeQt.sh 
./RespeQt.sh: 37: /home/dl7ukk/ATARI/Respe/bin/RespeQt: Permission denied
dl7ukk@Hp635b:~/ATARI/Respe$ sudo ./RespeQt.sh 
[sudo] Passwort für dl7ukk: 
./RespeQt.sh: 37: /home/dl7ukk/ATARI/Respe/bin/RespeQt: Permission denied
dl7ukk@Hp635b:~/ATARI/Respe$ 

lg
dl7ukk

Online
JoSch
Beiträge: 200
Registriert: 25.08.2021 21:40
Has thanked: 91 times
Been thanked: 72 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von JoSch »

Code: Alles auswählen

chmod u+x RespeQt.sh
chmod u+x bin/RespeQt
Das ist noch ein TODO.

Benutzeravatar
dl7ukk
Beiträge: 554
Registriert: 25.08.2021 23:03
Has thanked: 77 times
Been thanked: 106 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von dl7ukk »

.
Bilder sagen mehr wie meine Worte
.
wsx.png
wsx.png (110.96 KiB) 370 mal betrachtet
.
Danke :!: :!: :!:

dl7ukk

Online
JoSch
Beiträge: 200
Registriert: 25.08.2021 21:40
Has thanked: 91 times
Been thanked: 72 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von JoSch »

Gerne.

Der Installer macht übrigens auch nicht viel anderes, als die Dateien in einem Verzeichnis Deiner Wahl abzulegen und ein Deinstaller mit dazuzupacken. Essentiell ist das auch eine portable Version.

Benutzeravatar
GoodByteXL
Beiträge: 265
Registriert: 18.08.2021 12:10
Has thanked: 6 times
Been thanked: 60 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von GoodByteXL »

JoSch hat geschrieben:
14.05.2024 09:10
Ich habe auch eine gezippte Datei hinterlegt. RespeQt muss dabei mit dem Shellskript gestartet werden. Funktioniert diese Version nicht bei Dir?
Man sehe es mir nach, dass ich nur Anwender bin und deswegen einfache Point&Click-Lösungen benötige.

Mir fehlte diese Information dazu. Es funktioniert. Danke für die Hilfe - auch an dl7ukk.

Die DEB-Datei meldet sich mit,
Bildschirmfoto vom 2024-05-15 09-31-13.png
Bildschirmfoto vom 2024-05-15 09-31-13.png (43.62 KiB) 338 mal betrachtet
was für mich nicht nach einer portablen Version aussah.

Online
JoSch
Beiträge: 200
Registriert: 25.08.2021 21:40
Has thanked: 91 times
Been thanked: 72 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von JoSch »

Die Deb-Datei meinte ich nicht mit Installer. Es gibt noch die Datei InstallerRespeQt_5.4.0.run. Diese meinte ich.

Benutzeravatar
atarixle
Beiträge: 283
Registriert: 18.06.2021 21:19
Has thanked: 32 times
Been thanked: 52 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von atarixle »

JoSch hat geschrieben:
14.05.2024 10:02

Code: Alles auswählen

chmod u+x RespeQt.sh
chmod u+x bin/RespeQt
Das ist noch ein TODO.
ZIP merkt sich keine Datei-Rechte. Es wäre besser, Programme für Linux und macOS als .tar.xz oder .tar.gz zu verteilen.

GoodByteXL hat geschrieben:
15.05.2024 09:34
JoSch hat geschrieben:
14.05.2024 09:10
Ich habe auch eine gezippte Datei hinterlegt. RespeQt muss dabei mit dem Shellskript gestartet werden. Funktioniert diese Version nicht bei Dir?
Man sehe es mir nach, dass ich nur Anwender bin und deswegen einfache Point&Click-Lösungen benötige.

Mir fehlte diese Information dazu. Es funktioniert. Danke für die Hilfe - auch an dl7ukk.

Die DEB-Datei meldet sich mit,

Bildschirmfoto vom 2024-05-15 09-31-13.png

was für mich nicht nach einer portablen Version aussah.
Aus irgend einem Grund werden auf deinem System .deb-Dateien als (gzip-)Archiv geöffnet. Früher, als GNOME noch wirklich benutzerfreundlich war, wurden .deb-Dateien mit gdebi geöffnet, von dem aus man das .deb-Archiv gleich installieren konnte.

Benutzeravatar
atarixle
Beiträge: 283
Registriert: 18.06.2021 21:19
Has thanked: 32 times
Been thanked: 52 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von atarixle »

GoodByteXL hat geschrieben:
14.05.2024 08:29
JoSch hat geschrieben:
10.05.2024 09:28
Ich habe gerade die neue Version 5.4.0 H.A.T.Z. Edition veröffentlicht.
Ich habe unter anderem noch die Logausgabe begrenzt, so dass bei längerer Benutzung keine Crashes mehr vorkommen sollten.
https://github.com/josch1710/RespeQt/re ... tag/r5.4.0

Viel Spass.
Ich war längere Zeit offline ...

Was ich vermisse, ist eine portable Version für Linux, wie sie früher Mirko erstellt hatte. In github kann ich nur zu installierende oder zu kompilierende Versionen finden.

Eine Version wie die letzte von Mirko erstellte Fassung http://atarixle.ddns.net/download/respe ... _64.tar.xz wäre hilfreich (für mich zumindest).
Hab ich soeben erstellt. Siehe: http://atarixle.ddns.net/download/#respeqt
Diese Builds sind inoffiziell, ungetestet, nicht unterstützt. Aber vielleicht nutzen sie jemandem. Wichtig: ich habe das unter debian 9 für x86 und x64 gebaut.
Meine alten Builds sind hier auch noch zu finden.

Online
JoSch
Beiträge: 200
Registriert: 25.08.2021 21:40
Has thanked: 91 times
Been thanked: 72 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von JoSch »

atarixle hat geschrieben:
15.05.2024 14:56
JoSch hat geschrieben:
14.05.2024 10:02

Code: Alles auswählen

chmod u+x RespeQt.sh
chmod u+x bin/RespeQt
Das ist noch ein TODO.
ZIP merkt sich keine Datei-Rechte. Es wäre besser, Programme für Linux und macOS als .tar.xz oder .tar.gz zu verteilen.
Das stimmt so nicht. Info-Zip kann das und die meisten haben das installiert.
CQtDeployer hat leider keine Funktion, um Tar-Achive zu erzeugen.
Eher würde ich Zip ganz weglassen und mich auf Installer.run verlassen, was etwas komfortabler (Stichwort Point&Click) das Archiv auspackt.

Benutzeravatar
atarixle
Beiträge: 283
Registriert: 18.06.2021 21:19
Has thanked: 32 times
Been thanked: 52 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von atarixle »

Ich habe soeben meinen debian 9 32 Bit Build auf meinem alten Intel Atom unter debian 11 ausprobiert.

Aber irgendwie bleibt meine Druckerausgabe stehts weiß. Welche Dateien brauche ich in meinem Installationsverzeichnis, damit ich da was sehe?

Online
JoSch
Beiträge: 200
Registriert: 25.08.2021 21:40
Has thanked: 91 times
Been thanked: 72 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von JoSch »

atarixle hat geschrieben:
15.05.2024 15:51
Ich habe soeben meinen debian 9 32 Bit Build auf meinem alten Intel Atom unter debian 11 ausprobiert.

Aber irgendwie bleibt meine Druckerausgabe stehts weiß. Welche Dateien brauche ich in meinem Installationsverzeichnis, damit ich da was sehe?
Kannst Du mir etwas genauer erklären, was Du machst.

Benutzeravatar
GoodByteXL
Beiträge: 265
Registriert: 18.08.2021 12:10
Has thanked: 6 times
Been thanked: 60 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von GoodByteXL »

atarixle hat geschrieben:
15.05.2024 14:56
Aus irgend einem Grund werden auf deinem System .deb-Dateien als (gzip-)Archiv geöffnet. Früher, als GNOME noch wirklich benutzerfreundlich war, wurden .deb-Dateien mit gdebi geöffnet, von dem aus man das .deb-Archiv gleich installieren konnte.
Ähm, das denke ich nicht ...

Die DEB-Datei wird mit gdebi-gtk (https://manpages.debian.org/buster/gdeb ... .1.en.html) gestartet.

Benutzeravatar
atarixle
Beiträge: 283
Registriert: 18.06.2021 21:19
Has thanked: 32 times
Been thanked: 52 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von atarixle »

Oh. Klar. Da ist ja der "Installieren"-Button. Hab mich wohl strengstens verguckt.
Ich war wohl irritiert von der Dateiliste.

Zum Drucken:
In RespeQt aktiviere ich den Drucker 1 als Atari 1029.
Dann lade ich ein Bild in Graphics 8 und aktiviere die Ausgabe des Graphics-8-Bildschirms auf dem Drucker. Die Druckroutine hab ich mal bei KE-Soft abgetippt und ist für den 1029er Drucker gedacht. Die Daten werden von RespeQt auch klaglos angenommen, aber die Anzeige bleibt leer. Mein realer 1029er Drucker druckt das Bild aber fehlerfrei aus.

Danach hab ich es nochmal mit einem simplen LPRINT "Dies ist ein Test" versucht, aber die Anzeige bleibt leer.

Online
JoSch
Beiträge: 200
Registriert: 25.08.2021 21:40
Has thanked: 91 times
Been thanked: 72 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von JoSch »

atarixle hat geschrieben:
16.05.2024 07:44
[..]
Zum Drucken:
[..]
Danach hab ich es nochmal mit einem simplen LPRINT "Dies ist ein Test" versucht, aber die Anzeige bleibt leer.
Ja, leider ist die ganze Drucksimulation steckengeblieben, weil ich ja alles (fast) alleine mache und die ganze Struktur mich ziemlich an einer sinnvollen Implemenation hindert. Wahrcheinlich muss ich alles rauswerfen bis auf den Textdruck, damit man wenigstens Text exportieren kann.

Benutzeravatar
GoodByteXL
Beiträge: 265
Registriert: 18.08.2021 12:10
Has thanked: 6 times
Been thanked: 60 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von GoodByteXL »

JoSch hat geschrieben:
16.05.2024 09:04
Wahrcheinlich muss ich alles rauswerfen bis auf den Textdruck, damit man wenigstens Text exportieren kann.
Das liest sich für mich so, als ob der bis RespeQt 4.0 vorhandene Textdruck da noch irgendwo möglich ist. Eine versteckte Option oder falsche Hoffnung?

Die Emulation der verschiedenen Atari-Drucker durch eine Emulation eines 9-Nadlers mit Epson-Standard zu ersetzen kommt mir nützlicher vor.

Online
JoSch
Beiträge: 200
Registriert: 25.08.2021 21:40
Has thanked: 91 times
Been thanked: 72 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von JoSch »

Die Idee war, dass man die Textdrucke direkt als Textdatei speichern kann. Naja, ist alles Sch***e im Moment.
Ich schaue mal, ob ich hier wenigstens ein Fortschritt machen kann.

Currock
Beiträge: 42
Registriert: 18.08.2021 17:31
Has thanked: 3 times
Been thanked: 3 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von Currock »

JoSch hat geschrieben:
12.05.2024 20:44
Komisch, ich hatte mit der Version auf Windows in den letzten keine Probleme.
Welches Betriebssystem benutzt Du?
Debian 12. Unter Windows hat es immer funktioniert, das ist aber nicht das Thema. Es geht um Linux.

Currock
Beiträge: 42
Registriert: 18.08.2021 17:31
Has thanked: 3 times
Been thanked: 3 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von Currock »

Major Blink hat geschrieben:
13.05.2024 14:49
Hast Du auch den FTDI-Treiber installiert?
Ich habe nichts zusätzlich installiert. Für Linux sollte ähnliches gelten wie für Apple, die FTDI-Module sind schon integriert. Und der Atariserver läuft ja auch über genau dieses Interface.

Online
JoSch
Beiträge: 200
Registriert: 25.08.2021 21:40
Has thanked: 91 times
Been thanked: 72 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von JoSch »

Currock hat geschrieben:
17.05.2024 20:37
JoSch hat geschrieben:
12.05.2024 20:44
Komisch, ich hatte mit der Version auf Windows in den letzten keine Probleme.
Welches Betriebssystem benutzt Du?
Debian 12. Unter Windows hat es immer funktioniert, das ist aber nicht das Thema. Es geht um Linux.
Ich habe ja auch nur von mir gesprochen, da ich keine Ahnung hatte, was Du benutzt.
Allerdings kann ich jetzt nur mal mit meinem Ubuntu-basierten System testen. Ich sage Dir dann Bescheid.

Currock
Beiträge: 42
Registriert: 18.08.2021 17:31
Has thanked: 3 times
Been thanked: 3 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von Currock »

JoSch hat geschrieben:
17.05.2024 23:32
Ich habe ja auch nur von mir gesprochen, da ich keine Ahnung hatte, was Du benutzt.
Allerdings kann ich jetzt nur mal mit meinem Ubuntu-basierten System testen. Ich sage Dir dann Bescheid.
Danke! :) Ich warte gespannt. Vielleicht mache ich ja grundsätzlich irgend etwas verkehrt. Deine Einstellungen und die Hardware wären interessant.

Benutzeravatar
GoodByteXL
Beiträge: 265
Registriert: 18.08.2021 12:10
Has thanked: 6 times
Been thanked: 60 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von GoodByteXL »

Currock hat geschrieben:
17.05.2024 20:37
JoSch hat geschrieben:
12.05.2024 20:44
Komisch, ich hatte mit der Version auf Windows in den letzten keine Probleme.
Welches Betriebssystem benutzt Du?
Debian 12. Unter Windows hat es immer funktioniert, das ist aber nicht das Thema. Es geht um Linux.
Unter Ubuntu 2310 läuft es problemlos. Hat das nicht schon Debian 12 als Unterbau?

Debian 12 hatte ich probiert und wieder gelöscht, ist halt immer noch sehr spröde in der Benutzung.

Online
JoSch
Beiträge: 200
Registriert: 25.08.2021 21:40
Has thanked: 91 times
Been thanked: 72 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von JoSch »

Currock hat geschrieben:
18.05.2024 21:33
JoSch hat geschrieben:
17.05.2024 23:32
Ich habe ja auch nur von mir gesprochen, da ich keine Ahnung hatte, was Du benutzt.
Allerdings kann ich jetzt nur mal mit meinem Ubuntu-basierten System testen. Ich sage Dir dann Bescheid.
Danke! :) Ich warte gespannt. Vielleicht mache ich ja grundsätzlich irgend etwas verkehrt. Deine Einstellungen und die Hardware wären interessant.
Du kannst vielleicht noch einen Test machen:

Code: Alles auswählen

ls /dev/tty*
ausführen mit und ohne Adapter. Wenn es ein Device dazukommt, dann bitte dieses eintragen in RespeQt. Wenn nicht, gibt es keinen passenden Treiber für den Adapter in Deinem System.

Benutzeravatar
dl7ukk
Beiträge: 554
Registriert: 25.08.2021 23:03
Has thanked: 77 times
Been thanked: 106 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von dl7ukk »

Hi,

mit Ubuntu-Mate 22.04 läuft es sogar auf meiner gammligen Hardware, sogar mit unterschiedlichen USB-TTL Sticks

Code: Alles auswählen

[ 3517.902397] usb 5-1.3: new full-speed USB device number 4 using xhci_hcd
[ 3518.007001] usb 5-1.3: New USB device found, idVendor=067b, idProduct=2303, bcdDevice= 3.00
[ 3518.007030] usb 5-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 3518.007042] usb 5-1.3: Product: USB-Serial Controller
[ 3518.007051] usb 5-1.3: Manufacturer: Prolific Technology Inc.
[ 3518.718894] usbcore: registered new interface driver usbserial_generic
[ 3518.721553] usbserial: USB Serial support registered for generic
[ 3518.742734] usbcore: registered new interface driver pl2303
[ 3518.744770] usbserial: USB Serial support registered for pl2303
[ 3518.745470] pl2303 5-1.3:1.0: pl2303 converter detected
[ 3518.757905] usb 5-1.3: pl2303 converter now attached to ttyUSB0

          
[ 4315.049155] usb 5-1.3: new full-speed USB device number 5 using xhci_hcd
[ 4315.170144] usb 5-1.3: New USB device found, idVendor=0403, idProduct=6001, bcdDevice= 6.00
[ 4315.170172] usb 5-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4315.170184] usb 5-1.3: Product: FT232R USB UART
[ 4315.170193] usb 5-1.3: Manufacturer: FTDI
[ 4315.170201] usb 5-1.3: SerialNumber: AD028PB2
[ 4315.444142] usbcore: registered new interface driver ftdi_sio
[ 4315.444205] usbserial: USB Serial support registered for FTDI USB Serial Device
[ 4315.444433] ftdi_sio 5-1.3:1.0: FTDI USB Serial Device converter detected
[ 4315.444553] usb 5-1.3: Detected FT232R
[ 4315.451856] usb 5-1.3: FTDI USB Serial Device converter now attached to ttyUSB0

[ 4729.061053] usb 5-1.3: new full-speed USB device number 6 using xhci_hcd
[ 4729.179452] usb 5-1.3: New USB device found, idVendor=0403, idProduct=6001, bcdDevice= 6.00
[ 4729.179473] usb 5-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4729.179483] usb 5-1.3: Product: Sio2pc-USB www.lotharek.pl
[ 4729.179491] usb 5-1.3: Manufacturer: FTDI
[ 4729.179497] usb 5-1.3: SerialNumber: A9YL1A4B
[ 4729.188236] ftdi_sio 5-1.3:1.0: FTDI USB Serial Device converter detected
[ 4729.188367] usb 5-1.3: Detected FT232R
[ 4729.197266] usb 5-1.3: FTDI USB Serial Device converter now attached to ttyUSB1


Frohe Pfingsten

dl7ukk

Currock
Beiträge: 42
Registriert: 18.08.2021 17:31
Has thanked: 3 times
Been thanked: 3 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von Currock »

GoodByteXL hat geschrieben:
19.05.2024 08:51
Currock hat geschrieben:
17.05.2024 20:37
JoSch hat geschrieben:
12.05.2024 20:44
Komisch, ich hatte mit der Version auf Windows in den letzten keine Probleme.
Welches Betriebssystem benutzt Du?
Debian 12. Unter Windows hat es immer funktioniert, das ist aber nicht das Thema. Es geht um Linux.
Unter Ubuntu 2310 läuft es problemlos. Hat das nicht schon Debian 12 als Unterbau?

Debian 12 hatte ich probiert und wieder gelöscht, ist halt immer noch sehr spröde in der Benutzung.
Ja, bei mir hats auch ein bisschen gedauert, bis ich Debian überall auf die Version 12 angehoben habe. Läuft jetzt aber.

Zum Thema: AspeQT genau so wie RespeQT hatte ich schon in den Vorgänger-Versionen unter Debian 10 und 11 (auch 32bit-Version) getestet, hat auch da schon nicht funktioniert.
Komisch ist ja, dass der atariserver genau über diese Schnittstelle und diesem System funktioniert.

Currock
Beiträge: 42
Registriert: 18.08.2021 17:31
Has thanked: 3 times
Been thanked: 3 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von Currock »

dl7ukk hat geschrieben:
19.05.2024 10:20
Hi,

mit Ubuntu-Mate 22.04 läuft es sogar auf meiner gammligen Hardware, sogar mit unterschiedlichen USB-TTL Sticks

Frohe Pfingsten

dl7ukk

Code: Alles auswählen

 4758.421795] usb 2-3.4.4: new full-speed USB device number 8 using ehci-pci
[ 4758.537026] usb 2-3.4.4: New USB device found, idVendor=0403, idProduct=6001, bcdDevice= 6.00
[ 4758.537034] usb 2-3.4.4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4758.537038] usb 2-3.4.4: Product: USB Serial Converter
[ 4758.537042] usb 2-3.4.4: Manufacturer: FTDI
[ 4758.537044] usb 2-3.4.4: SerialNumber: FTFRUHAA
[ 4758.540194] ftdi_sio 2-3.4.4:1.0: FTDI USB Serial Device converter detected
[ 4758.540241] usb 2-3.4.4: Detected FT232R
[ 4758.540834] usb 2-3.4.4: FTDI USB Serial Device converter now attached to ttyUSB0
Die Schnittstelle ist da, der atariserver funktioniert ja auch genau darüber.

Currock
Beiträge: 42
Registriert: 18.08.2021 17:31
Has thanked: 3 times
Been thanked: 3 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von Currock »

JoSch hat geschrieben:
19.05.2024 09:10
Du kannst vielleicht noch einen Test machen:

Code: Alles auswählen

ls /dev/tty*
ausführen mit und ohne Adapter. Wenn es ein Device dazukommt, dann bitte dieses eintragen in RespeQt. Wenn nicht, gibt es keinen passenden Treiber für den Adapter in Deinem System.
Die Schnittstelle ist da, das wäre ja auch zu einfach. Hier, damit man es auch sehen kann:

Code: Alles auswählen

guido@CAGO:~$ ls /dev/tty*
/dev/tty    /dev/tty14  /dev/tty20  /dev/tty27  /dev/tty33  /dev/tty4   /dev/tty46  /dev/tty52  /dev/tty59  /dev/tty8
/dev/tty0   /dev/tty15  /dev/tty21  /dev/tty28  /dev/tty34  /dev/tty40  /dev/tty47  /dev/tty53  /dev/tty6   /dev/tty9
/dev/tty1   /dev/tty16  /dev/tty22  /dev/tty29  /dev/tty35  /dev/tty41  /dev/tty48  /dev/tty54  /dev/tty60  /dev/ttyS0
/dev/tty10  /dev/tty17  /dev/tty23  /dev/tty3   /dev/tty36  /dev/tty42  /dev/tty49  /dev/tty55  /dev/tty61  /dev/ttyS1
/dev/tty11  /dev/tty18  /dev/tty24  /dev/tty30  /dev/tty37  /dev/tty43  /dev/tty5   /dev/tty56  /dev/tty62  /dev/ttyS2
/dev/tty12  /dev/tty19  /dev/tty25  /dev/tty31  /dev/tty38  /dev/tty44  /dev/tty50  /dev/tty57  /dev/tty63  /dev/ttyS3
/dev/tty13  /dev/tty2   /dev/tty26  /dev/tty32  /dev/tty39  /dev/tty45  /dev/tty51  /dev/tty58  /dev/tty7   /dev/ttyUSB0
Ziehe ich den Adapter ab, fehlt /dev/ttyUSB0. Das ist es nicht.

Online
JoSch
Beiträge: 200
Registriert: 25.08.2021 21:40
Has thanked: 91 times
Been thanked: 72 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von JoSch »

Hast Du mal den AtariSIO-Modus probiert? Der geht nämlich meines Wissens durch das Kernelmodul, das atariserver auch nutzt.
Evtl. blockiert das Kernelmodul auch den Port und deswegen ist der Port nicht frei für die normale serielle Schnittstelle.

HiassofT
Beiträge: 149
Registriert: 17.08.2021 11:03
Wohnort: Salzburg, Austria
Has thanked: 12 times
Been thanked: 64 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von HiassofT »

Ich würd mal drauf tippen, dass die Probleme mit dem Atarimax Adapter mit den Modem Control Lines zusammenhängen.

In Atariserver setze ich sowohl DTR als auch RTS auf logisch low:
https://github.com/HiassofT/AtariSIO/bl ... #L291-L294

Code: Alles auswählen

	// clear DTR and RTS to make autoswitching Atarimax interface work
	flags &= ~(TIOCM_DTR | TIOCM_RTS);

	if (ioctl(fDeviceFileNo, TIOCMSET, &flags)) {
RespeQt hingegen scheint beide Leitungen auf logisch high zu setzen:
https://github.com/josch1710/RespeQt/bl ... pp#L97-L98

Code: Alles auswählen

    status |= (TIOCM_DTR | TIOCM_RTS);
    if (ioctl(mHandle, TIOCMSET, &status) < 0) {
Den meisten SIO2PC Adaptern ist der Zustand der Leitungen egal, aber IIRC verwenden die Atarmax Adapter DTR zum Umschalten zwischen SIO2PC und 1050-2-PC Modus (oder evtl auch nur zum Ein/Ausschalten des Adapters).

so long,

Hias

Online
JoSch
Beiträge: 200
Registriert: 25.08.2021 21:40
Has thanked: 91 times
Been thanked: 72 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von JoSch »

HiassofT hat geschrieben:
19.05.2024 14:37
Ich würd mal drauf tippen, dass die Probleme mit dem Atarimax Adapter mit den Modem Control Lines zusammenhängen.
[..]
Die Änderung wurde mal von TheMontezuma eingebaut (https://github.com/josch1710/RespeQt/co ... 9b3b8f3ad9).
Vorher wurden RTS, DTRund RI explizit gelöscht. Commit-Kommentar war: "- set DTR and RTS output lines on opening of the serial port (to support "Arduino Pro Micro" as SIO2PC)". Ich hatte mir scchon gedacht, dass das wieder so ein Fix für ein Spezialproblem ist.
Ganz ehrlich muss ich aber sagen, dass ich nur eine oberflächliche Ahnung von serieller Programmierung habe, und daher etwas überfragt im Moment, wie man das Problem für alle lösen kann.
Ich kann schlecht, alle verschiedenen Varianten von SIO2PC/USB/XYZ kaufen und jedesmal für alle Betriebssysteme durchtesten.
Wenn irgendjemand (@Hiassoft vielleicht Du) mit tieferen Wissen über serielle Programmierung mir mal auf die Sprünge helfen will, dann gerne drüben im Discord, oder sonstwo...

Benutzeravatar
DjayBee
Beiträge: 712
Registriert: 17.08.2021 04:02
Has thanked: 444 times
Been thanked: 208 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von DjayBee »

Mal ganz blauäugig und naiv gefragt:
Kann es sein, dass Currocks Linux-User nicht die notwendigen Rechte für den Zugriff auf /dev/tty/USBxy hat?

Online
JoSch
Beiträge: 200
Registriert: 25.08.2021 21:40
Has thanked: 91 times
Been thanked: 72 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von JoSch »

Hmm. Keine Ahnung, ob atariserver sich einfach auf das Kernelmodul stützt und welche Rechte es dafür braucht.
Aber schaden würde es sicher nicht, mal zu schauen, ob Currock in der Gruppe dialout ist.

HiassofT
Beiträge: 149
Registriert: 17.08.2021 11:03
Wohnort: Salzburg, Austria
Has thanked: 12 times
Been thanked: 64 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von HiassofT »

JoSch hat geschrieben:
20.05.2024 10:43
Die Änderung wurde mal von TheMontezuma eingebaut (https://github.com/josch1710/RespeQt/co ... 9b3b8f3ad9).
Vorher wurden RTS, DTRund RI explizit gelöscht. Commit-Kommentar war: "- set DTR and RTS output lines on opening of the serial port (to support "Arduino Pro Micro" as SIO2PC)". Ich hatte mir scchon gedacht, dass das wieder so ein Fix für ein Spezialproblem ist.
Also ich hör das erste Mal von einem "Arduino Pro Micro als SIO2PC".

Die Commit Message klingt für mich aber stark nach "wir haben da was zusammengebastelt dass nicht ganz OK ist und anstatt es zu fixen machen wir einfach RespeQt für Atarimax kaputt, das ist einfacher".

Probiert einfach mal die Änderung zurückzunehmen - der original Code hatte seinen Sinn und wenn das klappt übernehmt sie in den master / development Branch (auch für Win32, da scheint das ebenfalls geändert worden zu sein).

so long,

Hias

Online
JoSch
Beiträge: 200
Registriert: 25.08.2021 21:40
Has thanked: 91 times
Been thanked: 72 times
Kontaktdaten:

Re: RespeQt 5.4 RC3

Beitrag von JoSch »

atarixle hat geschrieben:
16.05.2024 07:44
Oh. Klar. Da ist ja der "Installieren"-Button. Hab mich wohl strengstens verguckt.
Ich war wohl irritiert von der Dateiliste.

Zum Drucken:
In RespeQt aktiviere ich den Drucker 1 als Atari 1029.
Dann lade ich ein Bild in Graphics 8 und aktiviere die Ausgabe des Graphics-8-Bildschirms auf dem Drucker. Die Druckroutine hab ich mal bei KE-Soft abgetippt und ist für den 1029er Drucker gedacht. Die Daten werden von RespeQt auch klaglos angenommen, aber die Anzeige bleibt leer. Mein realer 1029er Drucker druckt das Bild aber fehlerfrei aus.

Danach hab ich es nochmal mit einem simplen LPRINT "Dies ist ein Test" versucht, aber die Anzeige bleibt leer.
Du kannst mir helfen, in dem Du mir einen Snapshot von Deinem Druck machst.
Dazu gehe bitte in Optionen unter User Interface. In dem Panel ganz unten "Show debug menu" anhaken.
Nach Schließen der Optionen erscheint ein neuer Menüpunkt "Debug". Dort bitte "Capture snapshot" auswählen. Der Menüpunkt sollte jetzt einen Haken haben,
Mach bitte Deinen Druck. Zum Speichern des Snapshots wieder den Menüpunkt "Capture snapshot" auswählen. Jetzt erscheint ein Speicherdialog.
Schick dann bitte die gespeicherte Datei(en) an mich.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast